Accueil » Mettre à jour la version de PHP WordPress

Mettre à jour la version de PHP WordPress

by ghilo
WordPress

La mise à jour de la version PHP sur WordPress est l’une des activités les plus importantes à faire si vous voulez que votre site Web continue d’avoir des normes élevées de fiabilité et de sécurité pendant que les utilisateurs naviguent.

Malheureusement, de nombreuses sociétés d’hébergement continuent d’avoir une très ancienne version de PHP et ne sont donc plus prises en charge, ce qui entraîne une réduction des performances et des fonctionnalités.

Mais qu’est-ce que PHP exactement, pourquoi est-il essentiel de toujours le tenir à jour notamment lorsqu’il s’agit de sites WordPress et, surtout, comment effectuez-vous la tâche de mise à jour ?

Découvrons ensemble dans le guide qui suit où vous trouverez toutes les informations nécessaires pour mettre à jour la version PHP WordPress qui correspond à vos besoins.

Pourquoi mettre à jour wordpress vers la dernière version de PHP

PHP est un acronyme qui signifie « Hypertext Preprocessor » qui correspond à son tour à un langage de programmation couramment utilisé pour de nombreux sites Web et également par WordPress.

Chaque fois qu’une nouvelle version de PHP sort, les précédentes sont abandonnées, de sorte que tout site qui n’est pas à jour peut courir de sérieux risques de sécurité, ainsi que le risque de devenir incompatible avec le même plugin.

Actuellement, la version la plus récente de PHP est la 8.1, mais de nombreux hébergeurs proposent encore des versions plus anciennes qui ne sont plus prises en charge depuis des années. WordPress lui-même donne des indications précises en la matière : toutes les versions de PHP antérieures à la 7.4 ne sont plus supportées pour le moment, elles devront donc être modifiées ou mises à jour.

Liste de contrôle pour la mise à jour de php

Allons maintenant voir quelles sont les étapes de base pour mettre à jour la version PHP de WordPress.

Vérifiez la version de WordPress installée

Avant de passer à la mise à jour de la version PHP de votre site WordPress, il est indispensable d’effectuer quelques vérifications dont la première concerne la version de WordPress que vous avez installée sur votre site, ainsi que tous les plugins actifs. Cela vous aidera à comprendre si votre version de WordPress et ses plugins sont compatibles avec la version mise à jour de PHP que vous souhaitez installer.

Vous pouvez facilement vérifier la version de WordPress en cours d’exécution sur votre site en vous connectant au panneau d’administration via le lien www.sitename.com/wp-admin.

Une fois dans le panneau d’administration, accédez à la case « Résumé » du « Tableau de bord », où vous trouverez des informations concernant votre version de WordPress.

Après avoir vérifié la version de WordPress installée, vous devrez également vérifier que tous les plugins et thèmes installés sont mis à jour vers cette version.

Il est également conseillé à ce stade de supprimer tous les plugins et thèmes inactifs pour accélérer le site et le rendre plus efficace et fonctionnel.

Vérifier la version PHP installée sur le site WordPress

La deuxième étape essentielle consiste à vérifier la version de PHP installée sur le site WordPress.

Dans ce cas il suffira :

  • Entrez dans le tableau d’affichage ;
  • Allez dans « Outils-> Santé du site » ;
  • Cliquez sur le bouton « Informations » puis sur l’onglet « Serveur », où vous trouverez toutes les informations relatives au serveur dont la version de PHP utilisée.
  • Vérifier la compatibilité des plugins avec la version PHP à mettre à jour

Bien sûr, avant de mettre à jour votre PHP, vous devrez tester si la dernière version est également compatible avec tous vos thèmes et plugins utilisés sur votre site.

Cela peut être fait simplement en utilisant des plugins comme PHP Compatibility Checker . A l’issue du test, d’une durée de quelques minutes, le résultat pour chacun des plugins à utiliser sera l’un des suivants :

  • Compatible, dans ce cas vous pouvez procéder à la mise à jour sans plus attendre ;
  • Attention, cela signifie que quelque chose ne va pas, vous devrez donc effectuer d’autres vérifications sur la version à installer ;
  • Erreur, qui indique plutôt qu’il n’y a pas de compatibilité entre pulgin et la dernière version de php que vous souhaitez installer.

 Faire une sauvegarde du site

Avant de procéder à la mise à jour de la version php de WordPress, nous vous recommandons toujours de faire une sauvegarde de votre site WordPress, afin de ne pas perdre de données en cas de problème digitalequestrians.ch le fait pour vous.

Pour faire court, il existe au moins trois façons différentes de sauvegarder votre site WordPress :

  • Via votre plan d’hébergement si celui-ci offre évidemment un service de sauvegarde ;
  • Via un plugin payant;
  • Via la procédure manuelle directement depuis l’administrateur de votre site.
0 comment

Related Articles

Leave a Comment